
cbr:works 4
Frequently Asked Questions

Revision 2.1, 23 May 2000
 by tec:inno GmbH



Copyright  by tec:inno GmbH.
All rights reserved.

This document is subject to change without notice

Disclaimer:

THIS DOCUMENT IS PROVIDED FOR 
INFORMATIONAL PURPOSES ONLY. 

The information contained in this document represents 
the current view of TecInno on the issues discussed as 
of the date of publication. 

INFORMATION PROVIDED IN THIS DOCUMENT IS
PROVIDED ’AS IS’ WITHOUT WARRANTY OF ANY
KIND, EITHER EXPRESS OR IMPLIED, INCLUDING
BUT NOT LIMITED TO THE IMPLIED WARRANTIES
OF MERCHANTABILITY, FITNESS FOR A PARTICU-
LAR PURPOSE AND FREEDOM FROM INFRINGE-
MENT.

tec:inno GmbH

Sauerwiesen 2
D-67661 Kaiserslautern
Tel: +49 (0) 6301 606 400
Fax: +49 (0) 6301 606 409

cbrworks@tecinno.com
support@tecinno.com
www.tecinno.com



CBR-Works 4 - Frequently Asked Questions

3

Contents

1 General ................................................. 4

2 Filetypes...............................................8

3 Casebase............................................ 10

4 Concepts ............................................ 12

5 Types ..................................................13

6 Editors & Menus ................................ 16

7 Consultation....................................... 19

8 Similarity ............................................ 21

9 Handling .............................................25

10 Server ................................................. 27

11 CQL-related........................................ 29

12 CQLConnect....................................... 31

13 Database ............................................ 32

14 Model-Design-Tips ............................ 36

15 Rules................................................... 38



CBR-Works 4 - Frequently Asked Questions
1 General

• What is “CBR-Works for you“?

This CBR-Works-Starter remembers the last applica-
tion which you have worked with and its path, so you 
can easily restart it. 

Alternatively you can start each application with a 
double-click in your Explorer.

• What is a Domain?

By domain we denote the subject area of a CBR-
Works application.

• Do I really have to use an object-
oriented style to design my domain 
model?

or

• When is flat domain model sufficient?

Surely not, you can build your model in a flat way, 
but for advanced modellers it is recommended to use 
hierarchic concepts, because they can introduce some 
abstractions into the model, can use inheritance and 
on each level it restricts the domain to the essential 
part of the it. 
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• Which platforms are supported by 
CBR-Works?

Win9x / Win NT, Solaris, HP-UX, IBM-AIX, Apple 
Macintosh, OS/2

• I did “save Workspace” with another 
name. How can I start it?

or

• I have moved the CBR-Works-file to 
another location, Windows cannot start 
it any more using the START-menu?!

or

• I double-clicked the .cbr-file but there is 
no application connected to it. Which 
one should I use?

If Windows cannot start the file or link, go to the new 
location and double-click on the file with the exten-
sion “.cbr”. 

• My computer crashed (my model 
smashed), have I lost everything?

When ever you save your work by file-save, 
CBR-Works stores the file’s old version with the 
extension ’.bak’

No, during every saving CBR-Works creates (over-
writes) the bak-files. Thus you have the last version 
of your work still save.

To restore your work:

(1) Change to the directory named like your model
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(2) Remove the bak-extension from domain-
Model.bak and the version-files in the directory 
CaseBases 

(3) restore the old version by ...

• Will I run into inconsistencies when I 
change the model while having cases or 
is this checked by any tool?

Yes you will get inconsistencies, i.e. 

• you change the level of a subconcept to top-level 
then you loose all inherited attributes. 

• You have compiled some cases with the old model!

• There is no maintenance-tool yet to proof the con-
sistence, it’s a problem to know something about 
the semantics of changes - what does the user 
intent? It is necessary to copy all values from a case 
or not?
But this problem will be solved with the new ver-
sion with maintenance support.

• What about the support of multiple 
languages? - What happens, when I 
change to another language?

Queries and attribute names will be shown in differ-
ent languages. 

(Generally - this is not supported for Symbol values, 
yet.)
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• I got the message: 

but I’m using alphabetic characters?

Is it possible, that you use German “Umlaute“ like 
’ä’? - For example ’Gehäuse’ is not a correct Name 
for CBRWorks.
General 7
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2 Filetypes

• What does the filetype “.cbr” mean?

“cbr“ is the filename extension for the executable file 
of CBR-Works. 

After you have installed CBR-Works 3 properly, you 
can start it via Start menu or with a double-click on 
the filename with “.cbr“ or “.exe“ extension.

• What does the filetype “.cdm” mean?

A CDM-file is an ASCII file which describes your 
Case-Domain-Model, the model of the domain you 
are working with. This file will be created by choos-
ing the export-CQL-Model menu entry.

• What does the filetype “.cql” mean?

There are two possibilities to save your casebase. 
CBR-Works uses an internal format called BOSS 
(Binary Object Storage System) to save the cases in a 
binary format by default. Alternatively you can 
export your cases by choosing the 
“File>Export>CQL“ menu-entry to store them in 
an ASCII file format. This file gets the extension 
“.cql“. 

Binary files are smaller and load faster but ASCII 
files may be exchanged with other applications, can 
be edited by hand and it is the general exchange for-
mat for an update from an older to a newer version of 
CBR-Works.
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• What does the filetype “.cba” mean?

“cba“ is the extension for a CBR-Works application, 
that means, when you have finished your model and 
want to distribute an application, you can create it 
with “File>Deploy>Application“. An Appli-
cation is the small kind of CBR-Works, which does 
not allow any change or your model, it does not 
include the necessary editors.

• What does the filetype “.cbs” mean?

This extension stands for the CaseBase-Server Pro-
gram. That means, you have an application without 
any graphical user interface, you can communicate 
with this application over a network using CQL - the 
case query language. To create such an application 
use “File>Deploy>CQL-Server“.

• What does the filetype “.err” mean?

This file will help you, if you have some problems 
with CBR-Works. It includes the last error message 
of CBR-Works, so our support can infer, what your 
problem is.
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3 Casebase

• What is a “binary” casebase?

There are two possibilities to save your casebase. 
CBR-Works uses an internal format called BOSS 
(Binary Object Storage System) to save the cases in a 
binary format by default. Alternatively you can 
export your cases by choosing the 
“File>Export>CQL“ menu-entry to store them in 
an ASCII file format. Binary files are smaller and 
load faster but ASCII files may be exchanged with 
other applications and can be edited by hand.

• How do I unload my casebase or how 
do I load another one at the same time?

You can only handle one casebase at a time. You can 
unload (and save changes to your casebase) by choos-
ing new or load from the File-Menu. The old 
casebase will be saved and a new or the selected one 
appears.

To use two casebases at the same time you need to 
run two images, so start CBR-Works for each case-
base you want to use at the same time. 

• Since I have updated CBR-Works to a 
new version, my model can not be 
loaded!

CBR-Works stores your model and Case-Base in a 
binary format for fast access. But this format could be 
changed with an update of CBR-Works, therefore you 
Casebase 10
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will get a problem. The cleverest way is to use export 
and import all with CQL. 

A short description to rescue you work from an older 
version to a newer one: 

• Start the older version of CBR-Works and store 
your domain model and case base using 
“File>Export>CQL>Model“ and 
“File>Export>CQL>Case Base“.

• Import these files with the new version of CBR-
Works using “File>Import>CQL>Model“ and 
“File>Import>CQL>Case Base“.

For some description more detailed read the “Intro-
duction to CQL”-document!

• My Image has been grown very large, 
can I scale it down?

You can scale down your image (cbr-file) or any 
grew binary files in trying to export you model 
and your casebase using Export-CQL, then 
close your casebase and begin a new one. Last, 
just import the CLQ-files. Now the next “Save & 
Exit” should produce a minor size of your model 
and casebase. Please pay attention to have a 
backup of your work, before you try this solution. 

(For some description more detailed read the “Intro-
duction to CQL”-document.)
Casebase 11
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4 Concepts

• Why have Type-names and Concept-
names to be different?

or

• Why is it forbidden to name a Concept 
like a Type? 

The separation between the two words concept and 
type is only for the user, it is only a view. But our sys-
tem does not distinguish them, Types are atomar 
Concepts, for that reason all names have to be unique 
throughout CBR-Works.
Concepts 12
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5 Types

• When to use Symbol instead of String?

Strings and Symbols have a different internal repre-
sentation. 
Strings have three default-similarity-calculations:

(1) “exact match”, 

(2) “spelling-check” and 

(3) “word-count”

for descriptions on detail see the help-button, please.

Symbols know the identity as similarity-measure 
only, so if the query-symbol is identical to the case-
symbol, the similarity is 1, otherwise 0. 

For that reason, the calculation of symbol-similarities 
is faster than them of strings, but you have more pos-
sibilities to use the default-similarities of strings.

With Strings, you can handle any text-input and you 
could use this for comments or alike. You can search 
a word in a text for example.

• When to use OrderedSymbols?

With this subtype of Symbol you define an implicit 
similarity by the order you enumerate the symbols. 
Later you can refine the default-similarity of 
Ordered-Symbols adding your own similarity-func-
tion or -table. By default the nearest neighbour is 
more similar than the distant one.
Types 13
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• When to use TaxonomySymbol?

For a very good example of a taxonomy take a look at 
your tutorial: “The Second Application Model” -> 
“The Colour Problem”.

• When to use a SymbolSet?

With this Symbol-Subtype, you specify a set of sym-
bols. The similarity-calculation looks for the same 
elements in the query-set and the case-set. The more 
elements there are (related to the whole set), the 
higher is the similarity. 

Note: If you want to use your applications with data-
bases: Databases do not know sets, so you should not 
use this type.

• Can I change the supertype of any 
subtype? 

Yes, you can change your user-defined types by 
applying the change type wizard!

Select the type which you want to change and choose 
convert type in the context-menu.

• How to define an URL as an attribute-
value?

You can define an URL as an attribute just utilising 
the String-type but do not forget the pre-string “http:/
/“. The Online-Wizard will recognise this entry as a 
link to the specified internet-page.

• Time and Timestamp - what is the 
difference?

A Timestamp includes the date, time does not.
Types 14
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• How to define a Taxonomy?

Is it possible, that you have defined your “taxonomy“ 
with “Add subtype“ ? That’s not the appropriate tax-
onomy-editor!

Define a subtype of TaxonomySymbol, on the right 
side of the Tree-View the taxonomy-editor appears 
and you may define new values as sons of the prede-
fined root symbol. By selecting the root symbol and 
choosing rename from the context menu, you spec-
ify the name of your ’root’-symbol.

• How many cases can CBR-Works cope 
with? - What’s about the query time?

The response-time depends on: 

• how many attributes you have defined 

• the complexity of your similarity-measures 

• the power of your computer

• how many cases you store
Types 15
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6 Editors & Menus

• What does “Save Workspace” mean?

Save Workspace saves your work and the 
momentary state of the user interface to the harddisk, 
i.e., when you restart CBR-Works you can continue 
working at the point where you saved your work-
space or in other words: When you have opened your 
query-window on the evening and you want to pro-
ceed your query tomorrow.... then it is time to save 
your workspace. 

ATTENTION: “Save” or “Save & Exit” will 
only store your application data but not the state of 
the user interface you were working with and vice-
versa.

• Exit / Save&Exit - when should I use 
which one?

• Do you want to save your state of work - use Save 
& Exit. 

• If you want to save your opened windows too, use 
Save Workspace just before.

• Do you want to loose some modelling mistakes ....
use Exit (without saving you model and case base)

• What can I do by “Deploy > 
Application”?

or
Editors & Menus 16
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• What can I do by “Deploy > CQL- 
Server”?

By selecting these menu entries you may generate 
stand alone versions of your application that do not 
contain the editors that are provided with the devel-
opment version of CBR-Works.

The deployed application version allows to 
utilise the casebase for retrieval and to add and delete 
cases. This method delivers single-user CBR-Works-
Applications.

The deployed CQL-Server is utilised to deliver a 
multi-user client-server applica-
tion with CBR-Works. This creates the server soft-
ware that later can be accessed via CQL.

• What does the “Compile Menu” do?

Any changes to the domain model, i.e., types, values, 
concepts and attributes need to be translated into the 
underlying internal data structures of CBR-Works. 
This happens in the background while working with 
the system. Anyway, if changes made to the model 
appear not to have an effect in the casebase then man-
ually compiling the model will fix the problem.

• What does “Isolate concept“ mean?

This breaks the selected concept out of the hierarchy 
and sets it to the top-level, it inherited attributes will 
be removed from it’s definition. You can also use 
drag & drop to reorder the concepts.
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• What is the purpose of the “Dis”-
checkbox in the attribute list of the 
concept editor?

By checking this box you define, which attribute is 
enabled in a query. If there is no hook, then you can-
not query for this attribute. 

• What is the difference between 
“Graphics”, “Tree” and the “List 
View”? - When should I use which one?

Graphics and Tree give you a graphical overview of 
the concepts and types of your domain model. 

At the concepts-view, Display Graphics shows you 
the ’IS-A’-Hierarchy and the respective attributes of 
the concepts.

The Display Tree looks like your explorer and it is 
foldable. That means you can fold some sub-concepts 
or -attributes for a better overview, you have to dou-
ble-click on a concept to view some attributes.

If you are searching for a specific name, then the List 
View is the right one to apply, because all names are 
alphabetically ordered disregarding any hierarchic 
structures.
Editors & Menus 18



CBR-Works 4 - Frequently Asked Questions
7 Consultation

• Regular value / undefined value / 
unknown value - what is the difference?

If you are building a query, you can choose between 
this three types of attribute-settings. 

Regular value: You specify a value for the query. 

Value undefined: You do not want to specify this 
value for your retrieval, i.e. you will accept any val-
ues retrieved

Value unknown: You don’t know anything about this 
value, that means you will not be asked the system 
during retrieval for this value. 

• How to use a case as a query?

At the casebase-view you can select a case and then 
choose “Case as Query” at the “Case”-menu, 
change the view to “Query”.

• What is the Online-Wizard? 

or

• How do I use the Online-Wizard?

The OnlineWizard helps you to create a query to the 
CBR-Works-Server. This Wizard make out a list with 
these questions which are eligible for a query. 
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If you have started a HTTP-Server you can attempt to 
get a answer-catalogue with your internet-browser:

Type http://localhost:8008/launch/OnlineWizard at 
your location-prompt from your browser and answer 
some questions. 

• How do I start the Query-Wizard? 
When clicking the Query-Wizard-icon 
(light bulb) nothing happens!

Before you can start the Query-Wizard, you have to 
generate a new query case, then you can call the 
query-wizard by selecting the above mentioned icon.
Consultation 20



CBR-Works 4 - Frequently Asked Questions
8 Similarity

• How does CBR-Works calculate the 
defaultSimilarity-value of SymbolSets ?

Suppose you have defined a set of symbols T. The 
similarity between a query q and a case c will be cal-
culated as. 

That means, the more elements are in both sets 
related to the whole set, the better the similarity.

Alternatively, you can specify this one:

• Similarity-Editor: There are four Cards 
to define the Similarity, can I define all 
four variants?

No, you must select one option for your similarity-
definition or inheritance from the super concept. 

sim q c,( ) q c∪( ) q c∩( )–
T

---------------------------------------------=

q c∩
q c∪
----------------
Similarity 21
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• Similarity-Editors: What is the 
difference between linear and 
logarithmic scale?

Use the online-help of the similarity-editor.

• How does CBR-Works calculate the 
default-Similarity of integers?

By default the similarity of Integers will be calculated 
as follows:
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So similarity of 1,0 means that Integer1 is equal x 
(the given number to compare with). Otherwise the 
similarity is between 0 .. 1,0, a distance of the given 
numbers is calculated and adjusted to the range of 
integers (or your subtype).

similarity 1 0,
q c–

ub lb–( )
------------------------------

 
 
 

–=
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• I cannot edit the Similarity - what do I 
need to do?

The defaultSimilarity is not editable. You have to add 
your own similarity before you are able to edit it.

• How to implement my own similarity 
measures?

First you have to define your own (user-)type at the 
type-view, for example MyIntegerType.

In the Range-card you specify the range between 
your integer-type, the lower and the upper bound.

Add your similarity by choosing the Similarity-card . 
With “Edit” you have three possibilities to define 
your similarity (not all three together, only one of 
them). 

• How can I find/model similar text-
passages?

With CBR-Works you can define simply similarities 
about strings naturally you can use Strings as exten-
sive text-passages.
To define a similarity for a user-defined String first 
define such one, i.e., “MyString” as SubString of 
String. Then choose the Similarity-Card and add the 
Similarity you want to specify. With a click on 
“Edit” you can choose one of three possibilities of 
standard-similarity: 

(1) “exact match”, 

(2) “spelling-check” and 

(3) “word-count”.

There are respectively question marks at the 
selection points, which explain the background 
of these variants. 
Similarity 23
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• Why get new Similarities such strange 
names?

The name will be generated with the type-name and 
your similarity-name, so that the coherency is explic-
itly shown .

• What is the difference between 
symmetric / asymmetric similarity?

Suppose you are dealing with used cars and you wish 
to define the similarity between two car-brands: 
BMW and Opel. 

You can define a symmetrical one, perhaps 0,6 if you 
meant that both are similar to one another. But you 
can define the similarity asymmetric too, for exam-
ple: 
Similarity (BMW -> Opel) = 0,1 and 
Similarity (Opel -> BMW) = 0,7 even if Opel is more 
similar to BMW as contrariwise.
Similarity 24
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9 Handling

• How can I stop a CQL-Server?

Cause this service is a background-process and does 
not show any user-interface, you have to shut-down 
by utilising the taskmanager of your operating-sys-
tem. The task name is CBRWave.exe

• I want to select some fields on the lower 
left side of my Similarity-Array, but the 
program always selects on the upper 
right side!

You have selected the symmetric option for the simi-
larity table, i.e., for two values a and b the condition 
sim(a,b)=sim(b,a) holds. Therefore the editor mirrors 
the respective similarity from the upper right half to 
the lower left half of the table. If you wish to put dif-
ferent values for sim(a,b) and sim(b,a) select the 
asymmetric option above the table view.

• CBR-Works online refused an URL as 
being invalid?!

Reason: Is it possible, that you typed “\” instead 
of “/” ?
Solution: Retype your URL with “/”.
Handling 25
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• After I have installed CBR-Works, I 
want to run it the first time, it does not 
work - why?

There are the commonly known problems with long 
filenames under Windows 9x/NT!

If you are using spaces inside a path i.e., “program 
files” or “C:\Programme\CBR Works” you must put 
quotes -> “C:\Programme\CBR Works“ around your 
complete path.

The newest version of install-engine supports this 
quoting automatically.

• With File->open I have got an empty 
filerequest! - What is the matter?

You have to select a volume from the Volume drop 
down menu at the top of the file request dialogue. 
Depending on the operating system, you are working 
with, the volumes may appear differently.
Handling 26
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10 Server

• How do I use CBR-Online?

or 

• How to support my Client-Server-
Solution on the internet?

or

• How to create a HTTP-Server with 
CBR-Works?

(4) Select “Server Console” on the 
“Server”-Menu. 

(5) “Create Server” shows you an enlarged 
window

(6) Server Type: TinyHttpServer

(7) Hostname: localhost (if you try server-function-
ality on your own PC) or the servername where 
you installed CBR-Works.

(8) Port: default: 8008, but you can choose your 
own portnumber

(9) finally “Create and Start” your CBR-
Works-Onlineserver.
Server 27
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• Does the HTTP-Server start 
automatically?

Either you have to create & start / start it manually or 
you can select the option: “start server on 
system start-up”, then it starts automatically 
when you start CBR-Works.

• How to test CBR-Online?

CBR-Online is a generic web-interface. This means, 
you can ask CBR-Works over the internet. How to 
do...

Start a internet-browser and type the following path:
http://localhost:8008/launch/Online
if your CBR-Works is running on your PC, you have 
created a HTTP-Server and you let the port-number 
as default (8008) otherwise you have to give the 
name of the machine where CBR-Works is running 
and the port-number which you gave at creating the 
server.

• What to do with CQL-Server and how?

Read the “Introduction to CQL”-document, espe-
cially “Utilising CQL”. 

There is the description how to setup the CQL-Server 
too. 
Server 28
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11 CQL-related

• What is CQL?

or

• How do I correct typing errors, that 
occurred during the edition of a 
casebase?

or

• How to transfer a model or/and 
casebase with CBR-Works from an 
older version to a newer one?

or

• The casebase model is always 
modifiable. When you have included 
cases already, there is a problem to 
modify the model with underlying 
cases.

CQL is the Case-Query-Language for the CBR-
Works system. It is the interface language between all 
the CBR-Works component systems and it also 
serves as the interface language between the CBR-
Works-Server and the external world (clients), so it is 
a standard for exchanging information, especially to 
transfer a model and/or cases from an older CBR-
Works version to a newer one.
CQL-related 29
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CQL is an object-oriented language for storing and 
exchanging descriptive models and cases (libraries) 
in ASCII files and by transfer-protocol.

See the CQL-Documentation for more information.

• What is a CDM-File?

A CDM-file is the file which describes your Case-
Domain-Model, the model of the domain you are 
working with. This file will be created by choosing 
the export-CQL-Model menu entry.

• What should I do, if I must change my 
DomainModel and I want to reuse my 
work just done before?

or 

• What is the CQL-Interface - what does 
it do? What are its benefits?

To only save your model and cases, select ”File > 
Save“ or 
“File > Save as”, this stores your model and 
Case-Base in a binary format for fast access. But this 
is not the right way to change any version or update 
CBR-Works because the (binary) format could be 
changed and therefore you will get a problem. The 
cleverest but not easiest way is to use export and 
import all with CQL. For this advantage read the 
“Introduction to CQL”-document!

• What to do with CQL-Server and how?

Read the “Introduction to CQL”-document, espe-
cially “Utilising CQL”.
CQL-related 30



CBR-Works 4 - Frequently Asked Questions
12 CQLConnect

• How to run CQLConnect with 
Microsoft Internet Information Server?

or

• My HTML-Form for CQLConnect does 
not work and I use the MS Internet 
Information Server. What can I do 
about it?

Using Version 4 of the MS IIS, you have to create a 
virtual path in the Managment Console of the IIS to 
access the CQLConnect executable via WWW.

Furthermore, in this Version of MS IIS you cannot 
use the “GET” command for forms but the “POST” 
command.

• CQLConnect returns an error page on 
my browser, when I send my form after 
entering free text or numbers for values. 
What is wrong?

By the current Version of CQLConnect, no check is 
done on freely entered values whether they fit to the 
allowed set of values or not. This might be fixed in 
later releases.

For now, put the valid range aside the input area, so 
the user will know what values are allowed.
CQLConnect 31
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13 Database

• ODBC - what does it mean?

ODBC = Open DataBase Connectivity

A standard for accessing different database systems. 
There are interfaces for Visual Basic, Visual C++, 
SQL and the ODBC driver pack contains drivers for 
the Access, Paradox, dBase, Text, Excel and Btrieve 
databases. 

An application can submit statements to ODBC using 
the ODBC flavor of SQL. ODBC then translates 
these to whatever flavor the database understands. 
ODBC 1.0 was released in September 1992. 

ODBC is based on Call-Level Interface and was 
defined by the SQL Access Group. Microsoft was 
one member of the group and was the first company 
to release a commercial product based on its work 
(under Microsoft Windows) but ODBC is not a 
Microsoft standard (as many people believe). 

ODBC drivers and development tools are available 
now for Microsoft Windows, Unix, OS/2, and Macin-
tosh. 

• How to import data from a (ODBC-) 
database or Microsoft Access, MS-
Excel or alike?

You have to configure an ODBC-Stream, then you 
have to type the right “Database Options” at 
the CBR-Works > “File”-menu. 
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With “File > Settings > Database” (in 
newer Versions “File > Preferences > 
Database“) you can specify your database connec-
tion, supposing that a database is available.

Enter username, password and data-source (the name 
of your database).

Then - if no error occurred - you may create your 
concepts from the database: “Edit > Create 
Concepts from Database”. A concept-wizard 
appears so you can select the scheme(s), you want to 
import. 
For each table choose a primary key. 
“Create Concept” determines the selection proc-
ess for each table. 
“Done” quits the wizard and generates the chosen 
concepts.

If you have a complex scheme with some tables in 
relationship together, you have to define the first or 
top-table as case (context-menu: “Define as 
Case”). Now introduce CBR-Works to the relations 
between your tables.

At the concepts-view select the attributes-card and 
click on the type of a key that should refer to another 
table. The popup-button shows you a menu with all 
concepts and types, select the concept which is asso-
ciated with the appropriate table. CBR-Works knows 
that this name is related to another concept, but it 
does not guess, that it is a table of a database. Click 
on the database-card and select the foreign-key - at 
this point it is shown under “Attribute” - which is 
according to the corresponding table. The window 
extends. At the popup-menu button of “Foreign 
Key” select the (primary-) key of the corresponding 
table. When all relationships are defined, you can 
load the cases: “Edit > Add cases from 
Database”. 
Database 33



CBR-Works 4 - Frequently Asked Questions
• While importing concepts from a 
database this exception occurred:

What is the matter?

It seems that you tried to import a concept whose 
attributes are named with an identifier, that is used in 
the CBRWorks-System as unique symbol. For exam-
ple, id is often used as unique row-id, but id is a 
reserved word!

Solution: 

First close this requester with ’Terminate’. Sorry, 
but you have to delete the concerned concept. Now 
restart “Edit > Create Concepts from 
Database“. Then change “id“ into “product_id“ for 
example. 
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• I have problems importing data with 
ODBC from MS-Excel! 

You have to define a symbolic “Name” within MS-
Excel for the table you want to import. 

(1) Select the area which you want to use with 
ODBC.

(2) Select 
”Einfügen > Namen > Festlegen“ 
in the german version of Excel or 
"Insert > Name > Define" 
in the english version.

(3) Type a name and press OK.

Now you are able to import your data via ODBC.
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14 Model-Design-Tips

• I have designed a concept with 20 
attributes of type Boolean, but I’m 
unhappy to answer all of them if I want 
to set only a few of them to true.

You wish to model a subset of this attribute-set which 
are true. So why do you do not use the SymbolSet. 
You can specify a set of symbols - your 20 attributes 
and at the query you only have to select these 
attributes that you want to point out. This manner of 
modelling is recommended when you mostly want to 
select a few of all. 

Note: If you want to save your data into a relational 
database. This will not work, since they do not sup-
port sets as a datatype.

• I want to use a cyclic Type like 
weekdays for example, but there is no 
default type or appropriate default-
similarity?

Right, you have to define your own similarity-table 
like this one:
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That means, the direct neighbour of a weekday has a 
similarity-value of 0.8, the next only 0.6, the days 
which have the greatest distance to it, are not similar 
(similarity=0.0).
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15 Rules

• What is the difference between 
completion and adaptation rules?

Completion rules are used to complete a query or a 
case. Suppose you want to let rooms. Your rooms 
have a base price and you require an additional mark-
on of 30% for each person who rest in this room. You 
have designed your room-model with this base price 
and a variable number of persons. You can specify a 
completion rule, which calculate the full rental price. 

basePrice * person * 1,3 = rental-
Price

You give the basePrice and the number of Persons, 
then the full rentalPrice will automatically added to 
the case. 

Or another scenario: Suppose you configure a PC for 
consumers. You ask for the use of the PC and if the 
user says “for internet” you want to offer a modem. A 
completion rule can realize this fact. 

Adaptation Rules can be used to derive a new result 
case from the query and retrieved cases. You can 
economize a lot of work with this rule. Ever you have 
to do the same work, if the query has especially val-
ues and the retrieved cases fulfil some conditions, 
this work of creating new (adapted) cases will done 
of a adaptation rule. 

Take a look at the Reference Manual for a more 
detailed description of rules. 
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• When does a rule get started?

Completion rules are executed while entering the val-
ues of a case and, in case of retrieval, after all possi-
ble adaptation rules have fired. Some actions (i.e., 
weights, filter and similarity) are executed only for 
the current query and not for the cases in the case 
base. After each input of the user the rule system 
checks its rules. 

The adaptation rules are executed during a consulta-
tion session after the retrieval of cases. A result case 
is created by copying the retrieved case. All actions 
of the adaptation rules now refer to this result case 
rather than acting on the retrieved case or the query.

• What is the intension using rules?

Using rules you are able to catch some domain 
knowledge in mind and transfer it into the applica-
tion. Your application ’learn’ to react on defined con-
ditions of the query and case values. And you could 
economize the number of cases. Suppose you want 
different attribute values of a case depending on the 
actual time, e.g. . different wages for the usual work-
ing hours and a higher for working beyond this time. 
Normally these are two cases, but with a completion 
rule you are able to specify the rule to set the right 
wage for the appropriate time. 

• How to assign a calculated value to an 
attribute?

First save your calculation result in a temporary vari-
able using a condition rule then assign this value to 
the attribute in the rule’s action. 
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• How to extend the build-in functions of 
rules?

You are not allowed to change or extend the build-in 
functions. In such a case, please send a request to 
cbrworks@tecinno.com. 

• Is there any problem if a variable is 
named like an attribute of a concept?

No, there is no possibility for conflicts of attribute 
and variable names. 

• After defining a rule, CBR-Works never 
stops?!

Perhaps you created an infinite loop?! This behaviour 
is typically for a rule like...

condition: a greater 100
action: a := a + 5

This rule will usually cause an infinite execution of 
itself, once a is greater than 100, because a is 
increased with 5 and the rule fires again and again. 
But you can influence this behaviour by the rule’s 
preferences. Set the number of iterations greater than 
0 (the zero means infinite iterations). 

• When does an action of a rule fire, even 
if one or all conditions are true?

All conditions must be evaluated to true, then the rule 
will execute the defined action.
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• What to do if rules overwrite some 
values of other rules or user given 
values?

The preferences for rules allow detailed 
specification of how the rule mechanism 
will act on errors. See section 3.9.4.Rules 
Preferences Dialog Box of the Reference-
Manual getting more details. 

• I cannot assign the result of a 
calculation rule to an attribute?!

The type of the variable must be the same as the type 
of the attribute. You must ensure this by adding a 
condition which patches the type of your variable to 
the user defined type after the calculation, e.g. 
?x be_of_type <your>Type
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